$re = '/республик(?:а|и)\s*([\s\S]*?)\s*край\s*\(\s*область\s*\)\s*([^\n]*?)\s*\n(?:район\s*([^\n]*?)\s*\n)?нас\.\s*пункт\s*([^\n]*?)\s*\n/iu';
$str = 'Республика ХХХХХХХ
ХХХХХ
ХХХХХ
Край( область ) ХХХХХХ
Район ХХХХХХХХ
Нас.пункт ХХХХХХХХХ
РеспубликиХХХХХХХ
ХХХХХ
ХХХХХ
Край(область)ХХХХХХ
Нас.пунктХХХХХХХХХ
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);