import Foundation
let pattern = #"^\["(\w+):([\w\/]+)",({.+})\]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"["room:W8N3",{"objects":{"d880e9fb4db05ad":{"type":"extension","x":12,"y":15,"room":"W8N3","notifyWhenAttacked":true,"user":"8298a7fc8da7826","energy":50,"energyCapacity":50,"hits":1000,"hitsMax":1000,"_id":"d880e9fb4db05ad","meta":{"revision":11,"created":1545091396827,"version":0,"updated":1545179440937},"$loki":2426,"off":false},"26f20772347f879":{"room":"W8N3","type":"source","x":30,"y":21,"energy":2628,"energyCapacity":3000,"ticksToRegeneration":300,"_id":"26f20772347f879","meta":{"revision":15334,"created":1477476557639,"version":0,"updated":1545187606928},"$loki":41,"invaderHarvested":43640,"nextRegenerationTime":40410},"1bc30772347c388":{"room":"W8N3","type":"controller","x":23,"y":42,"level":2,"_id":"1bc30772347c388","meta":{"revision":26317,"created":1477476557639,"version":0,"updated":1545187606928},"$loki":42,"user":"8298a7fc8da7826","progress":34494,"downgradeTime":45342,"safeMode":20214,"safeModeAvailable":1},"2a01e5078a3444b":{"type":"extension","x":17,"y":8,"room":"W8N3","notifyWhenAttacked":true,"user":"8298a7fc8da7826","energy":50,"energyCapacity":50,"hits":1000,"hitsMax":1000,"_id":"2a01e5078a3444b","meta":{"revision":49,"created":1545086204067,"version":0,"updated":1545187586808},"$loki":2309,"off":false},"eaab9d9fe113376":{"type":"extension","x":18,"y":15,"room":"W8N3","notifyWhenAttacked":true,"user":"8298a7fc8da7826","energy":50,"energyCapacity":50,"hits":1000,"hitsMax":1000,"_id":"eaab9d9fe113376","meta":{"revision":59,"created":1545011330577,"version":0,"updated":1545186855126},"$loki":2088,"off":false},"68574f603b64a4a":{"type":"extension","x":13,"y":16,"room":"W8N3","notifyWhenAttacked":true,"user":"8298a7fc8da7826","energy":24,"energyCapacity":50,"hits":1000,"hitsMax":1000,"_id":"68574f603b64a4a","meta":{"revision":47,"created":1544929280950,"version":0,"updated":1545186778789},"$loki":2052,"off":false},"02c131b4b35fc35":{"type":"extension","x":17,"y":14,"room":"W8N3","notifyWhenAttacked":true,"user":"8298a7fc8da7826","energy":50,"energyCapacity":50,"hits":1000,"hitsMax":1000,"_id":"02c131b4b35fc35","meta":{"revision":76,"created":1544898169653,"version":0,"updated":1545186862442},"$loki":1680,"off":false},"8b333fad7cf3839":{"type":"road","x":32,"y":24,"room":"W8N3","notifyWhenAttacked":true,"hits":4900,"hitsMax":5000,"nextDecayTime":40978,"_id":"8b333fad7cf3839","meta":{"revision":38,"created":1545181255631,"version":0,"updated":1545187490436},"$loki":2988},"02e23f76b43fbd0":{"type":"road","x":33,"y":23,"room":"W8N3","notifyWhenAttacked":true,"hits":4900,"hitsMax":5000,"nextDecayTime":40926,"_id":"02e23f76b43fbd0","meta":{"revision":39,"created":1545181031235,"version":0,"updated":1545187486066},"$loki":2986},"48f4405ad177bb1":{"type":"road","x":27,"y":29,"room":"W8N3","notifyWhenAttacked":true,"hits":4900,"hitsMax":5000,"nextDecayTime":41173,"_id":"48f4405ad177bb1","meta":{"revision":30,"created":1545181965591,"version":0,"updated":1545187516157},"$loki":2992},"c3dd2579eeb7576":{"type":"road","x":23,"y":33,"room":"W8N3","notifyWhenAttacked":true,"hits":1900,"hitsMax":5000,"nextDecayTime":40387,"_id":"c3dd2579eeb7576","meta":{"revision":892,"created":1544885346027,"version":0,"updated":1545187606928},"$loki":1387},"7c4244ee65e5d5d":{"name":"u2","x":23,"y":33,"body":[{"type":"move","hits":100},{"type":"move","hits":100},{"type":"work","hits":100},{"type":"carry","hits":100},{"type":"move","hits":100},{"type":"move","hits":100},{"type":"work","hits":100},{"type":"carry","hits":100}],"energy":0,"energyCapacity":100,"type":"creep","room":"W8N3","user":"8298a7fc8da7826","hits":800,"hitsMax":800,"spawning":false,"fatigue":0,"notifyWhenAttacked":true,"_id":"7c4244ee65e5d5d","meta":{"revision":119,"created":1545186764382,"version":0,"updated":1545187606928},"$loki":3058,"ageTime":41716,"actionLog":{"attacked":null,"healed":null,"attack":null,"rangedAttack":null,"rangedMassAttack":null,"rangedHeal":null,"harvest":null,"heal":null,"repair":null,"build":null,"say":null,"upgradeController":null,"reserveController":null}},"71ac0772347ffe6":{"room":"W8N3","type":"source","x":34,"y":20,"energy":2654,"energyCapacity":3000,"ticksToRegeneration":300,"_id":"71ac0772347ffe6","meta":{"revision":15829,"created":1477476557639,"version":0,"updated":1545187223365},"$loki":40,"invaderHarvested":45324,"nextRegenerationTime":40385},"414c43b6b5ccf8f":{"name":"u1","x":24,"y":39,"body":[{"type":"move","hits":100},{"type":"move","hits":100},{"type":"work","hits":100},{"type":"carry","hits":100}],"energy":44,"energyCapacity":50,"type":"creep","room":"W8N3","user":"8298a7fc8da7826","hits":400,"hitsMax":400,"spawning":false,"fatigue":0,"notifyWhenAttacked":true,"_id":"414c43b6b5ccf8f","meta":{"revision":314,"created":1545185487708,"version":0,"updated":1545187606928},"$loki":3050,"ageTime":41492,"actionLog":{"attacked":null,"healed":null,"attack":null,"rangedAttack":null,"rangedMassAttack":null,"rangedHeal":null,"harvest":null,"heal":null,"repair":null,"build":null,"say":null,"upgradeController":{"x":23,"y":42},"reserveController":null}},"22134310feb709e":{"name":"h2","x":29,"y":20,"body":[{"type":"move","hits":100},{"type":"move","hits":100},{"type":"work","hits":100},{"type":"carry","hits":100}],"energy":22,"energyCapacity":50,"type":"creep","room":"W8N3","user":"8298a7fc8da7826","hits":400,"hitsMax":400,"spawning":false,"fatigue":0,"notifyWhenAttacked":true,"_id":"22134310feb709e","meta":{"revision":357,"created":1545184808939,"version":0,"updated":1545187606928},"$loki":3042,"ageTime":41383,"actionLog":{"attacked":null,"healed":null,"attack":null,"rangedAttack":null,"rangedMassAttack":null,"rangedHeal":null,"harvest":{"x":30,"y":21},"heal":null,"repair":null,"build":null,"say":null,"upgradeController":null,"reserveController":null}},"63243f756da9135":{"type":"road","x":29,"y":27,"room":"W8N3","notifyWhenAttacked":true,"hits":4900,"hitsMax":5000,"nextDecayTime":40969,"_id":"63243f756da9135","meta":{"revision":35,"created":1545181026010,"version":0,"updated":1545187505744},"$loki":2985},"eb513c77fa77fd9":{"type":"road","x":33,"y":22,"room":"W8N3","notifyWhenAttacked":true,"hits":4800,"hitsMax":5000,"nextDecayTime":41235,"_id":"eb513c77fa77fd9","meta":{"revision":58,"created":1545177890727,"version":0,"updated":1545187238469},"$loki":2953},"12d040b688cb9ba":{"type":"road","x":30,"y":26,"room":"W8N3","notifyWhenAttacked":true,"hits":4900,"hitsMax":5000,"nextDecayTime":41269,"_id":"12d040b688cb9ba","meta":{"revision":28,"created":1545182341260,"version":0,"updated":1545187500633},"$loki":3002},"351940b49d9c996":{"type":"road","x":31,"y":25,"room":"W8N3","notifyWhenAttacked":true,"hits":4900,"hitsMax":5000,"nextDecayTime":41258,"_id":"351940b49d9c996","meta":{"revision":29,"created":1545182333401,"version":0,"updated":1545187495424},"$loki":3001},"fa63428edc22526":{"name":"h1","x":14,"y":13,"body":[{"type":"move","hits":100},{"type":"move","hits":100},{"type":"work","hits":100},{"type":"carry","hits":100},{"type":"move","hits":100},{"type":"move","hits":100},{"type":"work","hits":100},{"type":"carry","hits":100}],"energy":26,"energyCapacity":100,"type":"creep","room":"W8N3","user":"8298a7fc8da7826","hits":800,"hitsMax":800,"spawning":false,"fatigue":0,"notifyWhenAttacked":true,"_id":"fa63428edc22526","meta":{"revision":468,"created":1545184275906,"version":0,"updated":1545187606928},"$loki":3031,"ageTime":41276,"actionLog":{"attacked":null,"healed":null,"attack":null,"rangedAttack":null,"rangedMassAttack":null,"rangedHeal":null,"harvest":null,"heal":null,"repair":null,"build":null,"say":null,"upgradeController":null,"reserveController":null}},"3fd6a82e9980b31":{"type":"spawn","room":"W8N3","x":17,"y":12,"name":"Spawn1","user":"8298a7fc8da7826","energy":300,"energyCapacity":300,"hits":5000,"hitsMax":5000,"spawning":null,"notifyWhenAttacked":true,"_id":"3fd6a82e9980b31","meta":{"revision":10664,"created":0,"version":0,"updated":1545187571438},"$loki":361,"off":false},"9020a8e6bb43797":{"type":"constructedWall","x":43,"y":5,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"9020a8e6bb43797","meta":{"revision":0,"created":1544754719669,"version":0},"$loki":458},"4647a99eaa84bb3":{"type":"constructedWall","x":43,"y":8,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"4647a99eaa84bb3","meta":{"revision":0,"created":1544755473064,"version":0},"$loki":471},"e9dfa9a0dad9c69":{"type":"constructedWall","x":43,"y":16,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"e9dfa9a0dad9c69","meta":{"revision":0,"created":1544755482029,"version":0},"$loki":472},"44e1a9b93cfc08a":{"type":"constructedWall","x":43,"y":6,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"44e1a9b93cfc08a","meta":{"revision":0,"created":1544755581904,"version":0},"$loki":474},"ce85a9b9a5d6c8b":{"type":"constructedWall","x":43,"y":7,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"ce85a9b9a5d6c8b","meta":{"revision":0,"created":1544755583581,"version":0},"$loki":475},"cf52a9baabed5d9":{"type":"constructedWall","x":43,"y":9,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"cf52a9baabed5d9","meta":{"revision":0,"created":1544755587775,"version":0},"$loki":481},"9731a9bb05da35d":{"type":"constructedWall","x":43,"y":14,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"9731a9bb05da35d","meta":{"revision":0,"created":1544755589213,"version":0},"$loki":483},"b3a9a9bb637b877":{"type":"constructedWall","x":43,"y":10,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"b3a9a9bb637b877","meta":{"revision":0,"created":1544755590711,"version":0},"$loki":484},"8735a9dc40ee5cf":{"type":"constructedWall","x":43,"y":11,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"8735a9dc40ee5cf","meta":{"revision":0,"created":1544755725326,"version":0},"$loki":493},"6d156164d0408e3":{"type":"mineral","mineralType":"H","mineralAmount":62196.64066651028,"x":9,"y":43,"room":"W8N3","_id":"6d156164d0408e3","meta":{"revision":1,"created":1477570874628,"version":0,"updated":1477570878159},"$loki":270,"density":3},"ba07aa406bcdfe2":{"type":"constructedWall","x":43,"y":12,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"ba07aa406bcdfe2","meta":{"revision":0,"created":1544756135612,"version":0},"$loki":523},"7cfbaa912e90613":{"type":"constructedWall","x":43,"y":15,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"7cfbaa912e90613","meta":{"revision":0,"created":1544756466409,"version":0},"$loki":572},"8333d934fe0fa3e":{"type":"road","x":25,"y":23,"room":"W8N3","notifyWhenAttacked":true,"hits":1200,"hitsMax":5000,"nextDecayTime":41172,"_id":"8333d934fe0fa3e","meta":{"revision":170,"created":1544805371872,"version":0,"updated":1545186626076},"$loki":611},"054edacc2145b4a":{"type":"constructedWall","x":43,"y":13,"room":"W8N3","notifyWhenAttacked":true,"hits":1,"hitsMax":300000000,"_id":"054edacc2145b4a","meta":{"revision":0,"created":1544807039508,"version":0},"$loki":665},"5866dee16fd64ad":{"type":"road","x":25,"y":24,"room":"W8N3","notifyWhenAttacked":true,"hits":1300,"hitsMax":5000,"nextDecayTime":40381,"_id":"5866dee16fd64ad","meta":{"revision":523,"created":1544811321085,"version":0,"updated":1545187294696},"$loki":765},"6761df93bf45eb7":{"type":"road","x":25,"y":26,"room":"W8N3","notifyWhenAttacked":true,"hits":1300,"hitsMax":5000,"nextDecayTime":40618,"_id":"6761df93bf45eb7","meta":{"revision":509,"created":1544812051444,"version":0,"updated":1545187284383},"$loki":789},"572fe230daf8be3":{"type":"road","x":23,"y":34,"room":"W8N3","notifyWhenAttacked":true,"hits":1100,"hitsMax":5000,"nextDecayTime":40449,"_id":"572fe230daf8be3","meta":{"revision":1154,"created":1544814792111,"version":0,"updated":1545187601611},"$loki":828},"3365e2ccbdadd33":{"type":"road","x":24,"y":30,"room":"W8N3","notifyWhenAttacked":true,"hits":1100,"hitsMax":5000,"nextDecayTime":40825,"_id":"3365e2ccbdadd33","meta":{"revision":1101,"created":1544815430618,"version":0,"updated":1545187531202},"$loki":829},"4af9e39609b029a":{"type":"road","x":25,"y":29,"room":"W8N3","notifyWhenAttacked":true,"hits":1100,"hitsMax":5000,"nextDecayTime":41005,"_id":"4af9e39609b029a","meta":{"revision":1101,"created":1544816255131,"version":0,"updated":1545187526260},"$loki":830},"7fb9e94ef499ede":{"type":"road","x":25,"y":21,"room":"W8N3","notifyWhenAttacked":true,"hits":1700,"hitsMax":5000,"nextDecayTime":40695,"_id":"7fb9e94ef499ede","meta":{"revision":74,"created":1544822255433,"version":0,"updated":1545186942744},"$loki":977},"1c83ea08a801f15":{"type":"road","x":25,"y":22,"room":"W8N3","notifyWhenAttacked":true,"hits":1700,"hitsMax":5000,"nextDecayTime":40926,"_id":"1c83ea08a801f15","meta":{"revision":61,"created":1544823016064,"version":0,"updated":1545185125765},"$loki":978},"a7c4eab7e2cd86b":{"type":"road","x":25,"y":20,"room":"W8N3","notifyWhenAttacked":true,"hits":1300,"hitsMax":5000,"nextDecayTime":41051,"_id":"a7c4eab7e2cd86b","meta":{"revision":969,"created":1544823733804,"version":0,"updated":1545187531202},"$loki":979},"e68b356505b0216":{"type":"road","x":26,"y":29,"room":"W8N3","notifyWhenAttacked":true,"hits":4700,"hitsMax":5000,"nextDecayTime":40582,"_id":"e68b356505b0216","meta":{"revision":60,"created":1545170473051,"version":0,"updated":1545187520632},"$loki":2850},"c2e4f3691fa406d":{"type":"road","x":25,"y":27,"room":"W8N3","notifyWhenAttacked":true,"hits":1700,"hitsMax":5000,"nextDecayTime":40659,"_id":"c2e4f3691fa406d","meta":{"revision":495,"created":1544832848378,"version":0,"updated":1545187278959},"$loki":1136},"63ebf450ccf3108":{"type":"road","x":25,"y":25,"room":"W8N3","notifyWhenAttacked":true,"hits":1700,"hitsMax":5000,"nextDecayTime":40858,"_id":"63ebf450ccf3108","meta":{"revision":485,"created":1544833797327,"version":0,"updated":1545187289576},"$loki":1137},"83b2f4c8a358d97":{"type":"road","x":23,"y":35,"room":"W8N3","notifyWhenAttacked":true,"hits":1500,"hitsMax":5000,"nextDecayTime":40523,"_id":"83b2f4c8a358d97","meta":{"revision":1015,"created":1544834288181,"version":0,"updated":1545187596704},"$loki":1139},"a5f3fb4802a7721":{"type":"road","x":23,"y":31,"room":"W8N3","notifyWhenAttacked":true,"hits":1600,"hitsMax":5000,"nextDecayTime":40689,"_id":"a5f3fb4802a7721","meta":{"revision":992,"created":1544841101354,"version":0,"updated":1545187536340},"$loki":1231},"4e4bfdb138c33ea":{"type":"road","x":23,"y":39,"room":"W8N3","notifyWhenAttacked":true,"hits":2000,"hitsMax":5000,"nextDecayTime":40415,"_id":"4e4bfdb138c33ea","meta":{"revision":306,"created":1544843629452,"version":0,"updated":1545187324796},"$loki":1292},"fb69fdb36c85fa6":{"type":"road","x":25,"y":28,"room":"W8N3","notifyWhenAttacked":true,"hits":1900,"hitsMax":5000,"nextDecayTime":40802,"_id":"fb69fdb36c85fa6","meta":{"revision":453,"created":1544843638472,"version":0,"updated":1545187274733},"$loki":1293},"b543fdd85c05ca0":{"type":"road","x":23,"y":38,"room":"W8N3","notifyWhenAttacked":true,"hits":1700,"hitsMax":5000,"nextDecayTime":40743,"_id":"b543fdd85c05ca0","meta":{"revision":944,"created":1544843789760,"version":0,"updated":1545187581044},"$loki":1301},"1d5ffe4a1fa2756":{"type":"road","x":23,"y":36,"room":"W8N3","notifyWhenAttacked":true,"hits":1700,"hitsMax":5000,"nextDecayTime":41197,"_id":"1d5ffe4a1fa2756","meta":{"revision":936,"created":1544844255738,"version":0,"updated":1545187591718},"$loki":1322},"8618fe5ab7b7a61":{"type":"road","x":23,"y":37,"room":"W8N3","notifyWhenAttacked":true,"hits":1700,"hitsMax":5000,"nextDecayTime":41281,"_id":"8618fe5ab7b7a61","meta":{"revision":933,"created":1544844323707,"version":0,"updated":1545187586808},"$loki":1327},"4c1f405bdd1d521":{"type":"road","x":28,"y":28,"room":"W8N3","notifyWhenAttacked":true,"hits":4900,"hitsMax":5000,"nextDecayTime":41174,"_id":"4c1f405bdd1d521","meta":{"revision":30,"created":1545181969873,"version":0,"updated":1545187510846},"$loki":2993},"be2725474803667":{"type":"road","x":23,"y":32,"room":"W8N3","notifyWhenAttacked":true,"hits":1800,"hitsMax":5000,"nextDecayTime":41269,"_id":"be2725474803667","meta":{"revision":894,"created":1544885138560,"version":0,"updated":1545187541394},"$loki":1376}},"users":{"2":{"_id":"2","username":"Invader"},"3":{"_id":"3","username":"Source Keeper"},"8298a7fc8da7826":{"steam":{"id":"76561198202242883"},"cpu":100,"cpuAvailable":10000,"registeredDate":"2018-12-14T02:16:00.471Z","credits":0,"gcl":34694,"_id":"8298a7fc8da7826","meta":{"revision":70713,"created":1544753760475,"version":0,"updated":1545187606948},"$loki":8,"active":10000,"blocked":false,"authTouched":true,"password":"nope","salt":"5d4413bc10c75835787ce205f3d7104d011ac04ba3c0630b276da96e727563c6","username":"Shecks","usernameLower":"shecks","badge":{"type":3,"color1":"#50bf35","color2":"#fdfdff","color3":"#e1b856","param":0,"flip":false},"rooms":["W8N3"],"lastUsedCpu":7,"lastUsedDirtyTime":13,"lastNotifyDate":1545157835228}},"flags":null,"info":{"mode":"world"}}]"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)