$re = '/"[^"\\\\]*(\\\\.[^"\\\\]*)*"/m';
$str = '"test1"
"test2" "test3"
"te\\"st4"
""
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);