import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!\\.)(?:(?:\\d{1,2}|1\\d{2}|2[0-4]\\d|25[0-5])\\.){3}(?:\\d{1,2}|1\\d{2}|2[0-4]\\d|25[0-5])(?!\\.)\\b";
final String string = "10.10.10.10\n\n"
+ "100.100.100.100\n\n"
+ "192.1.1.1.1\n\n"
+ "192.158.1.38\n\n"
+ "255.0.0.1\n\n"
+ "256.0.0.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}