package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\^\s*ro`)
var str = `CMyClass_NET^ roMyclass`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}