import re
regex = re.compile(r"(?:http|https|)(?::\/\/|)(?:www.|)(?:youtu\.be\/|youtube\.com(?:\/embed\/|\/v\/|\/watch\?v=|\/ytscreeningroom\?v=|\/feeds\/api\/videos\/|\/user\S*[^\w\-\s]|\S*[^\w\-\s]))([\w\-]{11})[a-z0-9;:@#?&%=+\/\$_.-]*", flags=re.IGNORECASE)
test_str = ("https://www.youtube.com/watch?v=N0bIBkXKbqI&feature=youtu.be\n"
"https://youtu.be/PTZI_QGhTlk\n"
"http://www.youtube.com/watch?v=-wtIMTCHWuI\n"
"http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
"http://youtu.be/-wtIMTCHWuI\n"
"http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
"https://www.youtube.com/embed/M7lc1UVf-VE\n\n"
"# NOT MATCHED\n"
"http://www.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
"https://www.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")