re = /([PDQE])(?:.*\1)?/m
str = 'FFFFRRFFFFFFFPPRRRRRRLLRLLRLLLPPFPPLPPLPPLFPPFFPFLRPFFRRLLRPFPRFFFFFFFLFDRRFRRFFFFFFFFRQEE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end