re = /^(?!.*@.*@)(?!.*\.\.)(^[a-zA-Z0-9._%+-]{1,64}@)([a-zA-Z0-9.-]+\.[a-zA-Z]{2,}(?:\.[a-zA-Z]{2,255})?)$/m
str = 'cxbersxnic@ravencode.ch'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end