# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<interface>\w+(?:\d/?)+(?:[\.]\d{1,3})?)\s+(?P<ip_address>(?:\w[\.]?)+)\s+(?P<ok>\w+)\s+(?P<method>\w+)\s+(?P<status>(?:\w+\s)?[\w]+)\s+(?P<protocol>\w+)"
test_str = ("Router# show ip interface brief\n"
"Interface IP-Address OK? Method Status Protocol\n"
"GigabitEthernet0/1 unassigned YES unset up up\n"
"GigabitEthernet0/2.1 192.168.190.235 YES unset up up\n"
"GigabitEthernet0/3 unassigned YES unset up up\n"
"GigabitEthernet0/4 192.168.191.2 YES unset up up\n"
"TenGigabitEthernet2/1 unassigned YES unset up up\n"
"TenGigabitEthernet2/2 unassigned YES unset up up\n"
"TenGigabitEthernet2/3 unassigned YES unset up up\n"
"TenGigabitEthernet2/4 unassigned YES unset down down\n"
"GigabitEthernet36/1 unassigned YES unset down down\n"
"GigabitEthernet36/2 unassigned YES unset down down\n"
"GigabitEthernet36/11 unassigned YES unset administratively down down\n"
"GigabitEthernet36/25 unassigned YES unset down down \n"
"Te36/45 unassigned YES unset down down\n"
"Te36/46 unassigned YES unset down down\n"
"Te36/47 unassigned YES unset down down\n"
"Te36/48 unassigned YES unset down down\n"
"Virtual36 unassigned YES unset up up")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.