$re = '/^(?:(0\d{10})|(\d{10})|(63\d{10}))\b/m';
$str = '09187654321
631111111111
1111111111
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);