re = /(?<=<).*?(?<name>\w+)=?(?<param>\w+)(?=>)/m
str = 'Sentence one<waitforkey=ok>
Sentence two<waitforkey=ok>
Sentence three'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end