re = /([^\s=;]+=\[[^][]*])|;/m
str = 'L=1nH;Tol=0.3nH;Idc=1000mA;Isat=NA;Iacpp=NA;Fr=10GHz;ESR=0.10ohm;Q=[100MegHz 7; 500MegHz 23;1.8GHz 47;2.4GHz 57];dL@Isat=NA;dT@Idc=NA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end