import re
regex = re.compile(r"<a\shref=.*?<\/a>", flags=re.MULTILINE)
test_str = ("<::after>\n"
"<!--::after-->\n"
"<div class=\"page-text-tmp\">\n"
" <h2 dir=\"ltr\">Габро — що за камінь?</h2>\n"
" <p dir=\"ltr\">Габро-діабаз відноситься до вулканічним гірським породам. Він знайшов широке поширення в сфері будівництва та архітектурного декорування. За своїми експлуатаційними характеристиками він нагадує граніт. Найчастіше камінь використовують для створення архітектурних елементів та виготовлення бруківки. Вироби з габро високо цінуються серед фахівців, тому й ціна у них відповідна.</p>\n"
" <p dir=\"ltr\">Наша компанія поставляє натуральний камінь <a href=\"/ua\">граніт</a> з різних країн світу. Габро-діабаз видобувають в Україні, Австралії і Карелії. Викопне з вітчизняних родовищ сьогодні користується особливою популярністю. Це зумовлено його високою механічною міцністю і простотою обробки. Завдяки цьому, з габро повсюдно виробляють плитку, сходи, сходи, бордюри і багато іншого. Купити будь-які з перерахованих виробів можна у нас. Ми гарантуємо вигідні умови співпраці та приємний сервіс.</p>\n"
" <h2 dir=\"ltr\">Якими перевагами володіє граніт габро?</h2>\n"
" <p dir=\"ltr\">Якщо ви вирішили придбати габро, граніт, зверніть увагу на каталог нашої компанії. Ми самостійно здійснюємо кінцеву обробку гірської породи і використовуємо сучасне високотехнологічне обладнання. У нашому асортименті представлені не тільки слеби, але і готові вироби з габро. Особливою популярністю серед клієнтів користується бруківка. Вона володіє тривалим терміном експлуатації і чудовим зовнішнім виглядом. Вся без винятку продукція з даного каменю має масу переваг. Серед них можна виділити:</p>\n"
" <ul dir=\"ltr\">\n"
" <li><::before>\n"
" <!--::before-->високі міцнісні характеристики;</li>\n"
" <li><::before>\n"
" <!--::before-->стійкість до впливу несприятливих кліматичних умов;</li>\n"
" <li><::before>\n"
" <!--::before-->здатність тривалий час зберігати якісне полірування;</li>\n"
" <li><::before>\n"
" <!--::before-->екологічна чистота і безпека;</li>\n"
" <li><::before>\n"
" <!--::before-->податливість до обробки;</li>\n"
" <li><::before>\n"
" <!--::before-->зносостійкість і довговічність.</li>\n"
" </ul>\n"
" <p dir=\"ltr\">Рекомендуємо звернути увагу на <a href=\"https://mramor-granit.com/ua/ukraine-granit\">українська граніт</a> габро Коростишів — камінь з вітчизняного родовища. Він відрізняється оригінальною текстурою і насиченим кольором. Сляби з цього копалин можна замовити оптом на вигідних умовах.</p>\n"
" <h2 dir=\"ltr\">Граніт габро — родовище якої країни віддати перевагу? </h2>\n"
" <p dir=\"ltr\">Видобуток граніту габро ведеться в декількох точках по всьому світу. Це Україна, Австралія і Карелія. В залежності від родовища, камінь може відрізнятися по текстурі і кольору. Найбільш якісним і естетичним вважається граніт габро Карелія. Він відрізняється повністю чорним кольором без будь-яких вкраплень і високими показниками морозостійкості. Матеріал досить міцний і зносостійкий, тому відмінно підходить для зовнішніх оздоблювальних робіт. Граніт габро Букинский — вітчизняний камінь, який видобувають в Житомирській області. Його головна перевага — більш демократична вартість. Що стосується, фізико-механічних та експлуатаційних властивостей, то він мало в чому поступається своєму закордонному побратимові. Якщо ви хочете замовити габро або <a href=\"https://mramor-granit.com/ua/anastasia-red\">анастасіївський граніт</a> від виробника «Металлстоун», тоді дзвоніть нам. Вся необхідна контактна інформація розташована у відповідному розділі сайту.</p>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")