package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+?)`)
var str = `csr= asdf fdsaf sa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}