package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)b?(?:.a)*`)
var str = `bcacaca dcaca dbcaca`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}