re = /^(?=.*[a-z])(?=.*[A-Z].*[A-Z])(?=.*[^\s]).{19,90}$/
str = 'aaaaaaaaaaaaaaaAbA$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end