# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\s]+<\/coordinates>[\s\S]+?<coordinates>[\s]+"
test_str = ("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
"<kml xmlns=\"http://www.opengis.net/kml/2.2\" xmlns:gx=\"http://www.google.com/kml/ext/2.2\" xmlns:kml=\"http://www.opengis.net/kml/2.2\" xmlns:atom=\"http://www.w3.org/2005/Atom\">\n"
"<Document>\n"
" <name>Example.kml</name>\n"
" <Style id=\"s_ylw-pushpin_hl\">\n"
" <IconStyle>\n"
" <scale>1.3</scale>\n"
" <Icon>\n"
" <href>http://maps.google.com/mapfiles/kml/pushpin/ylw-pushpin.png</href>\n"
" </Icon>\n"
" <hotSpot x=\"20\" y=\"2\" xunits=\"pixels\" yunits=\"pixels\"/>\n"
" </IconStyle>\n"
" <LineStyle>\n"
" <color>ffff00ff</color>\n"
" <width>4</width>\n"
" </LineStyle>\n"
" </Style>\n"
" <StyleMap id=\"m_ylw-pushpin\">\n"
" <Pair>\n"
" <key>normal</key>\n"
" <styleUrl>#s_ylw-pushpin</styleUrl>\n"
" </Pair>\n"
" <Pair>\n"
" <key>highlight</key>\n"
" <styleUrl>#s_ylw-pushpin_hl</styleUrl>\n"
" </Pair>\n"
" </StyleMap>\n"
" <Style id=\"s_ylw-pushpin\">\n"
" <IconStyle>\n"
" <scale>1.1</scale>\n"
" <Icon>\n"
" <href>http://maps.google.com/mapfiles/kml/pushpin/ylw-pushpin.png</href>\n"
" </Icon>\n"
" <hotSpot x=\"20\" y=\"2\" xunits=\"pixels\" yunits=\"pixels\"/>\n"
" </IconStyle>\n"
" <LineStyle>\n"
" <color>ffff00ff</color>\n"
" <width>4</width>\n"
" </LineStyle>\n"
" </Style>\n"
" <Folder>\n"
" <name>Example</name>\n"
" <open>1</open>\n"
" <Placemark>\n"
" <name>Untitled Path</name>\n"
" <styleUrl>#m_ylw-pushpin</styleUrl>\n"
" <LineString>\n"
" <tessellate>1</tessellate>\n"
" <coordinates>\n"
" 1.010794386877401,44.51240983736842,0 0.6286744887979312,47.46969863211312,0 4.198175193521713,47.66272708685459,0 4.47650525274385,45.32855385904715,0 \n"
" </coordinates>\n"
" </LineString>\n"
" </Placemark>\n"
" <Placemark>\n"
" <name>Untitled Path</name>\n"
" <styleUrl>#m_ylw-pushpin</styleUrl>\n"
" <LineString>\n"
" <tessellate>1</tessellate>\n"
" <coordinates>\n"
" 8.904276108011693,51.53463622874661,0 9.185337211508118,53.24757135457648,0 12.82197202867711,52.85957127892767,0 9.326760498064647,50.5694391186729,0 \n"
" </coordinates>\n"
" </LineString>\n"
" </Placemark>\n"
" <Placemark>\n"
" <name>Untitled Path</name>\n"
" <styleUrl>#m_ylw-pushpin</styleUrl>\n"
" <LineString>\n"
" <tessellate>1</tessellate>\n"
" <coordinates>\n"
" -0.8457721243506866,53.25357789001806,0 -2.495344342945436,52.51894778278026,0 -1.832838168564855,51.68947925151446,0 -0.004852378987588724,51.90053296811562,0 \n"
" </coordinates>\n"
" </LineString>\n"
" </Placemark>\n"
" </Folder>\n"
"</Document>\n"
"</kml>\n")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.