$re = '/(?i)^(?!TEA$)T.*A$/m';
$str = 'Theata
Tiora
Tooo
Tea';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);