const regex = new RegExp('^[0-9]*((0)1[23456789]|(0|1)2[3456789]|(0|1|2)3[456789]|(0|1|2|3)4[56789]|(0|1|2|3|4)5[6789]|(0|1|2|3|4|5)6[789]|(0|1|2|3|4|5|6)7[89]|(0|1|2|3|4|5|6|7)8(9))[0-9]*$', 'gm')
const str = `123
9876456000
123456789
246
91370
3456
111
415263
xyz123xyz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}