import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href\\W+=\\W+['|\\\"]([http|https]+://.+)['|\\\"]";
final String string = "<!DOCTYPE html>\n"
+ "<html lang=\"en\">\n"
+ "<head>\n"
+ " <meta charset=\"UTF-8\">\n"
+ " <title>网页加载中...</title>\n"
+ " <style type=\"text/css\">\n"
+ " .sk-three-bounce {\n"
+ " margin: 100px auto;\n"
+ " width: 80px;\n"
+ " text-align: center;\n"
+ "}\n"
+ ".sk-three-bounce .sk-child {\n"
+ " width: 20px;\n"
+ " height: 20px;\n"
+ " background-color: rgba(52, 214, 27, 0.76);\n"
+ " border-radius: 100%;\n"
+ " display: inline-block;\n"
+ " -webkit-animation: sk-three-bounce 1.4s ease-in-out 0s infinite both;\n"
+ " animation: sk-three-bounce 1.4s ease-in-out 0s infinite both;\n"
+ "}\n"
+ ".sk-three-bounce .sk-bounce1 {\n"
+ " -webkit-animation-delay: -0.32s;\n"
+ " animation-delay: -0.32s;\n"
+ "}\n"
+ ".sk-three-bounce .sk-bounce2 {\n"
+ " -webkit-animation-delay: -0.16s;\n"
+ " animation-delay: -0.16s;\n"
+ "}\n"
+ "@-webkit-keyframes sk-three-bounce {\n"
+ " 0%, 80%, 100% {\n"
+ " -webkit-transform: scale(0);\n"
+ " transform: scale(0);\n"
+ " }\n"
+ " 40% {\n"
+ " -webkit-transform: scale(1);\n"
+ " transform: scale(1);\n"
+ " }\n"
+ " \n"
+ "}\n"
+ "@keyframes sk-three-bounce {\n"
+ " 0%, 80%, 100% {\n"
+ " -webkit-transform: scale(0);\n"
+ " transform: scale(0);\n"
+ " }\n"
+ " 40% {\n"
+ " -webkit-transform: scale(1);\n"
+ " transform: scale(1);\n"
+ " }\n"
+ " \n"
+ "}\n"
+ "</style>\n"
+ "</head>\n"
+ "<body>\n"
+ "<div class=\"sk-three-bounce\">\n"
+ " <div class=\"sk-child sk-bounce1\"></div>\n"
+ " <div class=\"sk-child sk-bounce2\"></div>\n"
+ " <div class=\"sk-child sk-bounce3\"></div>\n"
+ "</div>\n"
+ "</body>\n"
+ "<script type=\"text/javascript\">\n"
+ " document.title = '网页加载中...';\n"
+ "var ua = navigator.userAgent;\n"
+ "if (ua.indexOf('MicroMessenger') > 0 ||ua.indexOf('QQ')>0||ua.indexOf('qq')>0) {\n"
+ " var noreferrer = true;\n"
+ " setTimeout(skip,1000)\n"
+ "}\n"
+ "else {\n"
+ " top.location.href = 'https://xw.qq.com';\n"
+ "};\n"
+ "function skip() {\n"
+ " if (top != window || !document.body) {\n"
+ " top.location.href = 'http://zruhdc.ddccee.top/travel_hot_gonglve_59721879943236';\n"
+ " }\n"
+ " else {\n"
+ " var a = document.createElement('a');\n"
+ " a.href = 'http://zruhdc.ddccee.top/travel_hot_gonglve_59721879943236';\n"
+ " if (noreferrer)\n"
+ " a.rel = 'noreferrer';\n"
+ " a.click();\n"
+ " }\n"
+ " \n"
+ "}\n"
+ "</script>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}