import Foundation
let pattern = #"(?i)^((Sráid|Bóthar)\s([a-záéíóú\s])+)|([a-z'\s]+?(\s)?(Street|Road|Lane|Green|Square|Avenue|Boulevard|Place|(St|Ave|Rd|Pl)(\.)?))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABBEY PARK
ABBEY STREET LOWER
ABBEY STREET MIDDLE
OLD ABBEY STREET
ABBEY STREET UPPER
ABBEYFIELD
ABBEYFIELD
ABBEYFIELD
ABBOTSTOWN AVENUE
ABBOTSTOWN DRIVE
ABBOTSTOWN ROAD
ABERCORN ROAD
ABERCORN TERRACE
ABERDEEN STREET
ACCOMMODATION WALK
ACCOMMODATION WALK
ACHILL ROAD
ADAIR LANE
ADAM COURT
ADARE AVENUE
ADARE DRIVE
ADARE GREEN
ADARE PARK
ADARE ROAD
ADDISON PLACE
ADDISON ROAD
ADELAIDE ROAD
ADRIAN AVENUE
AIDEEN AVENUE
AIDEEN DRIVE
AIDEEN PLACE
AIKENHEAD TERRACE
AILESBURY DRIVE
AILESBURY GARDENS
AILESBURY GARDENS
AILESBURY GROVE
AILESBURY MEWS
AILESBURY PARK
AILESBURY ROAD
AILESBURY ROAD
AILESBURY LANE
AIRFIELD COURT
AIRFIELD PARK
AIRFIELD ROAD
ALBANY ROAD
ALBANY ROAD
ALBERT COLLEGE AVENUE
ALBERT COLLEGE CRESCENT
ALBERT COLLEGE DRIVE
ALBERT COLLEGE GROVE
ALBERT COLLEGE LAWN
ALBERT COLLEGE PARK
ALBERT COURT EAST
ALBERT PLACE EAST
ALBERT PLACE WEST
ALBERT TERRACE
ALDBOROUGH PARADE
ALDBOROUGH PLACE
ALDBOROUGH SQUARE
ALDRIN WALK
ALEXANDRA TERRACE
ALEXANDER TERRACE
ALEXANDRA TERRACE
ALFIE BYRNE ROAD
ALL SAINTS DRIVE
ALL SAINTS PARK
ALL SAINTS PARK
ALL SAINTS ROAD
ALLINGHAM STREET
ALMA TERRACE
ALMEIDA AVENUE
AMIENS STREET
ANGLESEA ROAD
ANGLESEA ROW
ANGLESEA STREET
ANNA VILLA
ANNADALE AVENUE
ANNADALE CRESCENT
ANNADALE DRIVE
ANNADALE DRIVE
ANNALY ROAD
ANNALY ROAD
ANNAMOE DRIVE
ANNAMOE PARADE
ANNAMOE PARK
ANNAMOE ROAD
ANNAMOE TERRACE
ANNAMOE TERRACE
ANNE'S LANE
ANNE STREET NORTH
ANNE STREET SOUTH
ANNER ROAD
ANNESLEY AVENUE
ANNESLEY BRIDGE ROAD
ANNESLEY PARK
ANNESLEY PLACE
APPIAN WAY
APOLLO WAY
ARBOUR HILL
ARBOUR PLACE
ARBOUR TERRACE
ARBUTUS AVENUE
ARBUTUS PLACE
ARD NA MEALA
ARDPATRICK ROAD
ARD RI ROAD
ARD RI PLACE
ARDAGH ROAD
ARDARA AVENUE
ARDBEG CRESCENT
ARDBEG DRIVE
ARDBEG PARK
ARDBEG ROAD
ARDCOLLUM AVENUE
ARDEE ROAD
ARDEE STREET
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)