const regex = /client\s(?:\S+)\s(?<dns_request_client_ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}|(?:::)?(?:[a-zA-Z\d]{1,4}::?){1,7}[a-zA-Z\d]{0,4})#(?<dns_request_client_port>\d+).*\s(?<message_type>query):\s(?<dns_request_queried_domain>\S+)\s(?<dns_request_class_name>\w+)\s(?<dns_request_type_name>\w+)\s(?<dns_request_setDC>(?:\+|\-)\S*)\s\((?<dns_request_name_serverIP>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}|(?:::)?(?:[a-zA-Z\d]{1,4}::?){1,7}[a-zA-Z\d]{0,4})\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('client\\s(?:\\S+)\\s(?<dns_request_client_ip>\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}|(?:::)?(?:[a-zA-Z\\d]{1,4}::?){1,7}[a-zA-Z\\d]{0,4})#(?<dns_request_client_port>\\d+).*\\s(?<message_type>query):\\s(?<dns_request_queried_domain>\\S+)\\s(?<dns_request_class_name>\\w+)\\s(?<dns_request_type_name>\\w+)\\s(?<dns_request_setDC>(?:\\+|\\-)\\S*)\\s\\((?<dns_request_name_serverIP>\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}|(?:::)?(?:[a-zA-Z\\d]{1,4}::?){1,7}[a-zA-Z\\d]{0,4})\\)', 'gm')
const str = `client @0x7f9df0e8b720 11.11.111.11#12345 (helloworld.com): query: helloworld.com IN AAAA +E(0) (11.11.11.1)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);