re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])[-\w!$%^&*()_+|~=`{}\[\]:";'<>?,.\/]+$/
str = 'password$a1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end