re = /(?:[01]\d|2[0-3])(?::?[0-5]\d)?-(?:[01]\d|2[0-3])(?::?[0-5]\d)?/
str = '10:30-19:30
1030-1930
10-19'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end