import re
regex = re.compile(r"(?<!\[|\{|\(|#)(\b\d+\b)(?!\]|\}|\|st|nd|rd|th)", flags=re.MULTILINE)
test_str = ("123abd //should match 123\n"
"abc345 //should match 234\n"
"ab2123cd // should match 2123\n\n"
"{2}: Should NOT Match. //My regex Works\n\n"
"{34: Should NOT Match. //My regex matches 4 in {34\n\n"
"45}: Should NOT Match. //My regex matches 4 in {45\n\n"
"{123}: Should NOT Match. //My regex matches 2 in {123}\n\n"
"1st should NOT match\n"
"3th should NOT match, since it's wrong anyway\n"
"1nd should NOT match, since it's wrong anyway\n\n"
"14th //should NOT Match\n"
"14 th should Match")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")