package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:ha)+`)
var str = `hahaha, hah, haaha`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}