import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z\\u00C1\\u00C9\\u00CD\\u00D3\\u00DA\\u00DC\\u00E1\\u00E9\\u00ED\\u00F3\\u00FA\\u00FC\\u00D1\\u00F1]{1}[A-Za-z0-9\\u00C1\\u00C9\\u00CD\\u00D3\\u00DA\\u00DC\\u00E1\\u00E9\\u00ED\\u00F3\\u00FA\\u00FC\\u00D1\\u00F1\\,\\;\\:\\.@\\#\\$\\%\\&\\* \\-]+$";
final String string = "Éste es un regular expression creado para validar oraciones con caracteres de oraciones escritas en español. Puede ser utilizado para validar oraciones con vocales con acentos áéíóú, ÁÉÍÓÚ y u con diéresis Üü. No valida enters o líneas múltiples y tampoco oraciones con un espacio en el principio... por ejemplo. Aqui de romple la línea y se crea otra oración que parea con el regular expression...\n\n"
+ "ésta es la nueva línea.\n\n"
+ "El guión - es otro caracter que está permitido en el regular expression, y las comas , como pueden ver también. Ojo, de la misma manera que no se permite el uso del espacio al inicio de una oración tampoco se permite el uso de comas , o quipnes al inigio de la oración ejemplos que no parean con el regexp a continuación...\n\n"
+ "- esta oracion no hace match\n"
+ " ésta oración tampoco hace match\n"
+ ", ésta oración tampoco\n"
+ "por el con trario... ésta - otra horación sí parea con el regex.\n\n"
+ "José Manuel Rivera\n\n"
+ "El güiro mágico\n\n"
+ "La máquina de guerra.\n\n"
+ "ÁÉÍÓÚÜ áéíóúü\n\n"
+ "para que éste regex paree con párrafos, dene modificarlo cambiando el match del espacio por el scape character de los end of lines\n"
+ " - \\s.\n\n"
+ "De esa manera el RegExp. parea con parrafos y multiples lineas igual que con tabs y otros tipos de end of line characters.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}