re = /^(?=.*critical).*s?css$/m
str = 'critical.css
kjahsdjknasdcritical...skjdfnjsdf.css
jkjsfksndf,mnds.css'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end