$re = '/Ci.*o/m';
$str = 'Ciao
Ciadshfjeo
Cia1234o
Ciasrehjnc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);