$re = '/\[sid:(?<sid>[^\]]*)\]/m';
$str = 'A suspicious packet was sent [sid:2008518] -- Detected an attempt to make a configuration change in SQL DB using the legit \'sp_configure\' command The xp_cmdshell option is a SQL Server server configuration option that enables system administrators to control whether the xp_cmdshell extended stored procedure can be executed on a system. By default, the xp_cmdshell option is disabled on new installations. Before enabling this option, it is important to consider the potential security implications associated with the use of this option. It is proposed to disable the xp_cmdhsell option.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);