const regex = /(?i)^\S+\s+(?:[\/-]\S+\s+){0,100}[\/-]FORMAT:(?!(?:CSV|HFORM|HTABLE|LIST|MOF|RAWXML|TABLE|VALUE|XML))\S+\s+(?:[\/-]\S+(?:\s+|$)){0,100}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)^\\S+\\s+(?:[\\\/-]\\S+\\s+){0,100}[\\\/-]FORMAT:(?!(?:CSV|HFORM|HTABLE|LIST|MOF|RAWXML|TABLE|VALUE|XML))\\S+\\s+(?:[\\\/-]\\S+(?:\\s+|$)){0,100}$', 'gm')
const str = `windoof /FORMAT:CSV -all
windoof /FORMAT:LOL /?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}