$re = '/^((?:.{5})*)((?:.{2})*)$/m';
$str = '11111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);