package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9A-Z$/+%\-\. \\]+`)
var str = `123+456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}