#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(1(\s|-)?)?(\+\d{1,3}\s?)?((\(\d{3}\)\s?)|(\d{3})(\s|-?))(\d{3}(\s|-?))(\d{4})(\s?(([E|e]xt[:|.|]?)|x|X)(\s?\d+))?"
Local $sString = "/* Regular local phone number (XXX) XXX-XXXX */" & @CRLF & _
"1231231231" & @CRLF & _
"123-1231231" & @CRLF & _
"123123-1231" & @CRLF & _
"123-123 1231" & @CRLF & _
"123 123-1231" & @CRLF & _
"123-123-1231" & @CRLF & _
"(123)123-1231" & @CRLF & _
"(123)123 1231" & @CRLF & _
"(123) 123-1231" & @CRLF & _
"(123) 123 1231" & @CRLF & _
"1(212)2231141" & @CRLF & _
"1 232 442 1123" & @CRLF & _
"1-233-223-4433" & @CRLF & _
"12232234433" & @CRLF & _
"1(732) 1131131" & @CRLF & _
"" & @CRLF & _
"/* International codes +XXX (XXX) XXX-XXXX */" & @CRLF & _
"+99 1234567890" & @CRLF & _
"+991234567890" & @CRLF & _
"" & @CRLF & _
"/* Extensions (XXX) XXX-XXXX Ext. XXX... */" & @CRLF & _
"1234567890 Ext 1123123" & @CRLF & _
"1234567890Ext 1123123" & @CRLF & _
"1234567890 Ext1123123" & @CRLF & _
"1234567890Ext1123123" & @CRLF & _
"" & @CRLF & _
"1234567890 Ext: 1123123" & @CRLF & _
"1234567890Ext: 1123123" & @CRLF & _
"1234567890 Ext:1123123" & @CRLF & _
"1234567890Ext:1123123" & @CRLF & _
"" & @CRLF & _
"1234567890 Ext. 1123123" & @CRLF & _
"1234567890Ext. 1123123" & @CRLF & _
"1234567890 Ext.1123123" & @CRLF & _
"1234567890Ext.1123123" & @CRLF & _
"" & @CRLF & _
"1234567890 ext 1123123" & @CRLF & _
"1234567890ext 1123123" & @CRLF & _
"1234567890 ext1123123" & @CRLF & _
"1234567890ext1123123" & @CRLF & _
"" & @CRLF & _
"1234567890 ext: 1123123" & @CRLF & _
"1234567890ext: 1123123" & @CRLF & _
"1234567890 ext:1123123" & @CRLF & _
"1234567890ext:1123123" & @CRLF & _
"" & @CRLF & _
"1234567890 X 1123123" & @CRLF & _
"1234567890X1123123" & @CRLF & _
"1234567890X 1123123" & @CRLF & _
"1234567890 X1123123" & @CRLF & _
"1234567890 x 1123123" & @CRLF & _
"1234567890x1123123" & @CRLF & _
"1234567890 x1123123" & @CRLF & _
"1234567890x 1123123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")