re = /^[A-Za-z0-9_]+$/m
str = 'StackOverflow
Stack_Overflow
Stack-Overflow
Stack, Overflow'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end