# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\r\n]+(?<_KEY_1>[^\n:]+):(?<_VAL_1>[^\r\n]+)"
test_str = ("<plugin_output>\n"
"Path : /opt/AdoptOpenJRE/jdk8u332-b09-jre/\n"
"Version : 1.8.0_332\n"
"Binary Location : /opt/AdoptOpenJRE/jdk8u332-b09-jre/bin/java\n"
"Details : This Java install appears to be Java Runtime Environment, since\n"
"\"jre\" was found in the installation path and javac was not found\n"
"(medium confidence).\n"
"This Java install may be Oracle Java or OpenJDK Java due to\n"
"\"org.openjdk.java.util\" in the binary (low confidence).\n"
"Detection Method : \"find\" utility\n"
"</plugin_output>\n\n\n"
"Variation 2:\n\n"
"<plugin_output>\n"
"Path : /HP/hpoa/CADE2/HP/nonOV/openadaptor/1_6_5/classes/oa_jdk14_classes.jar\n"
"Version : 1.1.0\n"
"JMSAppender.class association : Found\n"
"JdbcAppender.class association : Found\n"
"JndiLookup.class association : Not Found\n"
"Method : MANIFEST.MF dependency\n"
"</plugin_output>\n\n\n"
"Variation 3:\n\n"
"<plugin_output>\n"
"Path : /opt/IBM/WebSphere855/AppServer/java_1.7_64/\n"
"Installed version : 7.0\n"
"Fixed version : 7.0.11.5\n\n"
"Path : /opt/IBM/WebSphere855/AppServer.old/java_1.7_64/\n"
"Installed version : 7.0\n"
"Fixed version : 7.0.11.5\n\n"
"Path : /opt/IBM/WebSphere855/AppServer.gagan/java_1.7_64/\n"
"Installed version : 7.0\n"
"Fixed version : 7.0.11.5\n\n"
"Path : /opt/IBM/InstallationManager/eclipse/jre_7.0.100001.20170309_1301/\n"
"Installed version : 7.0\n"
"Fixed version : 7.0.11.5\n"
"</plugin_output>\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.