re = /^\s*((?:\-\-.*?\n\s*)|(?:\/\*.*?(?=\*\/)\*\/\s*))*select\b/
str = '/**/ -- /*
/* test */
select'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end