import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(#EXTM3U\\s+|#EXTINF:\\d+,|(.*\\.\\w{3,4}).*\\s+)";
final String string = "#EXTM3U\n"
+ "#EXTINF:419,Alice in Chains - Rotten Apple\n"
+ "http://192.168.101.22:80/movies/9975.mkv\n"
+ "#EXTINF:260,Alice in Chains - Nutshell\n"
+ "http://192.168.101.22:80/movies/1254.mkv\n"
+ "#EXTINF:255,Alice in Chains - I Stay Away\n"
+ "http://192.168.101.22:80/movies/1254.mkv\n"
+ "#EXTINF:256,Alice in Chains - No Excuses\n"
+ "Alice in Chains_Jar of Flies_04_No Excuses.mp3\n"
+ "#EXTINF:157,Alice in Chains - Whale And Wasp\n"
+ "Alice in Chains_Jar of Flies_05_Whale And Wasp.mp3\n"
+ "#EXTINF:263,Alice in Chains - Don't Follow\n"
+ "Alice in Chains_Jar of Flies_06_Don't Follow.mp3\n"
+ "#EXTINF:245,Alice in Chains - Swing On This\n"
+ "Alice in Chains_Jar of Flies_07_Swing On This.mp3\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}