#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([+-])?(\d\d)\*(?:([0-5]\d)'(?:((?:[0-5]\d)(?:\.\d+)?))?")?([NS])?\/([+-])?([01]\d\d)\*([0-5]\d)'(?:(?:((?:[0-5]\d)(?:\.\d+)?))?")?([EW])?\s"
Local $sString = "7532N/10458W" & @CRLF & _
"7532/10458" & @CRLF & _
"753257/1045843" & @CRLF & _
"753257N/1045843E" & @CRLF & _
"753257.1/1045843.2 " & @CRLF & _
"753257.1N/1045843.2E" & @CRLF & _
"75:32N/104:58W" & @CRLF & _
"75:32/104:58" & @CRLF & _
"75:32:57/104:58:43" & @CRLF & _
"75:32:57N/104:58:43E" & @CRLF & _
"75:32:57.1/104:58:43.2" & @CRLF & _
"75:32:57.1N/104:58:43.2E" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"75*32/10458" & @CRLF & _
"75*32'57"N/104*58'43"E" & @CRLF & _
"75*32'57.1"/104*58'43.2"" & @CRLF & _
"75*32'57.1"N/104*58'43.2"E " & @CRLF & _
"" & @CRLF & _
"75:32/10458" & @CRLF & _
"75:3257N/104:58:43E" & @CRLF & _
"75:32:57.1/104:5843.2" & @CRLF & _
"75:32:57.1N/1045843.2E " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")