package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[\d]$|^[\d][\/\d]*[\d]$)`)
var str = `123//456
1
12
/123
123/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}