re = /[\\\/\/]/m
str = 'Aance petty cash - Site 21/03/2019||Y|17-OCT-19|17-OCT-19|17-OCT-19|KMADRZYK|MANUAL W|SAKM18OCT19|S|158 \\\\fpp01\\Finance\\Finance\\AP_PROCESSING\\1_MEN|SAR
Aance petty cash - Site 21/03/2019||Y|17-OCT-19|17-OCT-19|17-OCT-19|KMADRZYK|MANUAL W|SAKM18OCT19|S|\\krv|SAR
Aance petty cash - Site 21/03/2019||Y|17-OCT-19|17-OCT-19|17-OCT-19|KMADRZYK|MANUAL W|SAKM18OCT19|M|sd01\\Finance\\Finance\\AP_PROCESSING\\1_MEN |SAR
Aance petty cash - Site 21/03/2019||Y|17-OCT-19|17-OCT-19|17-OCT-19|KMADRZYK|MANUAL W|SAKM18OCT19|M|159\\fpp01\\Finance\\Finance\\AP_PROCESSING\\1_MEN |SAR
Studying and updating dmmmy ||Y|17-OCT-19|18-OCT-19|18-OCT-19|KMADRZYK|MANUAL W|SAKM18OCT19|T|160 -|SAR
Johannes Märkl Monatsrechnung ----||N|17-OCT-19|18-OCT-19|18-OCT-19|KMADRZYK|MANUAL W|SAKM18OCT19|S||SAR'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result