const regex = /(?<![^\W_])n(?:r?[_.]|umero_?)\s*\K\d+/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![^\\W_])n(?:r?[_.]|umero_?)\\s*\\K\\d+', 'gi')
const str = `\$t1 = "Disposizione n. 158 del 28.1.2012";
\$t2 = "Disposizione n.66 del 15.1.2006";
\$t3 = "Disposizione f_n_66 del 15.1.2001";
\$t4 = "Disposizione numero 66 del 15.1.2018";
\$t5 = "Disposizione nr. 66 del 15.1.2017";
\$t6 = "Disposizione nr_66 del 15.1.2016";
\$t7 = "Disposizione numero_66 del 15.1.2005";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}