$re = '/^(\s*)\S.*(?:\n(?:\1(?:\t|\s{4}).*)*)?/m';
$str = 'A b
C d
E
AA bb
CC dd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);