$re = '/[234]{10}[1-6]*?(?:6|5{6,})/m';
$str = '111112221111123232322342332465161532161232342342322224444223323555555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);