#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "</?(\\w+)>"
Local $sString = "<a \n name=toc>table of contents</a>" & @CRLF & _
"" & @CRLF & _
"<b>hello</b> world!" & @CRLF & _
"" & @CRLF & _
"<HTML>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")