$re = '/(\?|\&)([^=]+)\=([^&]+)/m';
$str = 'https://www.beispiel.de/haus/?dach=true&keller=false&garden=false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);