re = /(?<=[^\r\n])\r?\n(?!\r?\n)/
str = 'Строка один.
Строка два.
Строка три.
Строка четыре.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end