re = /(?!Split “S”)[Ss]plit[ -]“?[Ss]”?/m
str = 'split “S” Split-S Split S Split S, but not Split “S”'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end