package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<\!-- ct:.*? -->`)
var str = `<!-- ct:text -->keep me<!-- ct:hold -->`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}