const regex = /((^|\ )((\d{1,3})(.(\d{3}))+(\,\d{2}?€)))|(^|\ )((\d+(\,\d{2})?€)) /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^|\\ )((\\d{1,3})(.(\\d{3}))+(\\,\\d{2}?€)))|(^|\\ )((\\d+(\\,\\d{2})?€)) ', 'gm')
const str = `3,56€ 1000.000,00€ 3,568€ 1000.00,00€ 0.001.200
0,56 0,56€ 0,56 € 3€ 167.555.178,00€ 100.005.000,00€ 167.555,00€ 1.067,00€ 000.555
567.555,00€ 167.555,00€ 167.555,00€
100000,00€ 100000€
100.000.000,00€ 100.000000,00€`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}